Getbig Bodybuilding, Figure and Fitness Forums
October 20, 2014, 07:05:10 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: GOP strategist: We need Rubio because ‘he knows who Tupac is’  (Read 95 times)
blacken700
Getbig V
*****
Posts: 10933


Getbig!


« on: February 11, 2013, 06:38:21 AM »

 Cheesy Cheesy Cheesy Cheesy

Source: Raw Story

GOP strategist: We need Rubio because ‘he knows who Tupac is’
By Jonathan Terbush
Sunday, February 10, 2013 15:33 EST


Florida Sen. Marco Rubio has been hailed by many Republicans as the savior of the party, what with his youth, charisma and Cuban heritage.
 
Yet that’s not all he has to offer. According to one Republican strategist, the freshman Florida Senator also knows a little something about 90s rap music to boot.
 
Sunday on ABC’s This Week, GOP operative Nicole Wallace argued that Rubio was good for the party as a whole because, “he knows who Tupac is.” That knowledge, she said, proved that he could connect to young voters, a demographic the GOP has typically sruggled to court.
 
~snip~
Rep. Keith Ellison (D-MN) made that very point during the show.

“It’s like lipstick on a pig,” he said. “I mean, the bottom line is, the Republicans have a core values problem, not a ‘who knows who Tupac Shakur is’ problem.”
 
More:
http://www.rawstory.com/rs/2013/02/10/gop-strategist-we-need-rubio-because-he-knows-who-tupac-is/

Read more: http://www.rawstory.com/rs/2013/02/10/gop-strategist-we-need-rubio-because-he-knows-who-tupac-is/
Report to moderator   Logged
240 is Back
Getbig V
*****
Posts: 83987


Complete website for only $300- www.300website.com


WWW
« Reply #1 on: February 11, 2013, 09:58:16 AM »

awareness of 1993 gangsta rap is essential for our president.
Report to moderator   Logged

Pages: [1]   Go Up
  Print  
 
Jump to:  

Theme created by Egad Community. Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!